博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
hdu 1863 hdoj 1863
阅读量:4122 次
发布时间:2019-05-25

本文共 1535 字,大约阅读时间需要 5 分钟。

畅通工程

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7784    Accepted Submission(s): 2969
Problem Description
省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可)。经过调查评估,得到的统计表中列出了有可能建设公路的若干条道路的成本。现请你编写程序,计算出全省畅通需要的最低成本。
 
Input
测试输入包含若干测试用例。每个测试用例的第1行给出评估的道路条数 N、村庄数目M ( < 100 );随后的 N
行对应村庄间道路的成本,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间道路的成本(也是正整数)。为简单起见,村庄从1到M编号。当N为0时,全部输入结束,相应的结果不要输出。
 
Output
对每个测试用例,在1行里输出全省畅通需要的最低成本。若统计数据不足以保证畅通,则输出“?”。
 
Sample Input
3 31 2 11 3 22 3 41 32 3 20 100
 
Sample Output
3?
 
#include<iostream>
#include<stdio.h>
#include<cstdlib>
using namespace std;
typedef struct country{
    int x;
    int y;
    int weight;
}country;
int father[100];
int n,m;
int compare(const void *a,const void *b){
    return (*(country*)a).weight-(*(country*)b).weight;
}
void init(){
    for(int i=1;i<100;i++){
        father[i]=i;
    }
}
int find(int i){
    if(i!=father[i]){
        find(father[i]);
    }
    return father[i];
}
void unionfather(int a,int b){
    int x=find(a),y=find(b);
    if(x<y){
        father[y]=x;
    }
    else{
        father[x]=y;
    }
}
int lestcost(country *cou){
    int cost=0,count=0;
    init();
    for(int i=0;i<n;i++){
        if(find(cou[i].x)!=find(cou[i].y)){
            unionfather(cou[i].x,cou[i].y);
            cost+=cou[i].weight;
            count++;
        }
    }
    if(count!=m-1) cost=-1;
    return cost;
}
int main(){
    country cou[10000];
    int cost;
    while(scanf("%d%d",&n,&m),n!=0){
        for(int i=0;i<n;i++){
            scanf("%d%d%d",&cou[i].x,&cou[i].y,&cou[i].weight);
        }
        qsort(cou,n,sizeof(country),compare);
        cost=lestcost(cou);
        if(cost==-1) printf("?\n");
        else printf("%d\n",cost);
    }
    return 0;
}

转载地址:http://wxtpi.baihongyu.com/

你可能感兴趣的文章
Binary Tree Maximum Path Sum 自底向上求解(重重重重)
查看>>
Subsets 深搜
查看>>
Subsets II
查看>>
Edit Distance 字符串距离(重重)
查看>>
Gray Code 格雷码
查看>>
对话周鸿袆:从程序员创业谈起
查看>>
web.py 0.3 新手指南 - 如何用Gmail发送邮件
查看>>
web.py 0.3 新手指南 - RESTful doctesting using app.request
查看>>
web.py 0.3 新手指南 - 使用db.query进行高级数据库查询
查看>>
web.py 0.3 新手指南 - 多数据库使用
查看>>
一步步开发 Spring MVC 应用
查看>>
python: extend (扩展) 与 append (追加) 的差别
查看>>
「译」在 python 中,如果 x 是 list,为什么 x += "ha" 可以运行,而 x = x + "ha" 却抛出异常呢?...
查看>>
浅谈JavaScript的语言特性
查看>>
LeetCode第39题思悟——组合总和(combination-sum)
查看>>
LeetCode第43题思悟——字符串相乘(multiply-strings)
查看>>
LeetCode第44题思悟——通配符匹配(wildcard-matching)
查看>>
LeetCode第45题思悟——跳跃游戏(jump-game-ii)
查看>>
LeetCode第46题思悟——全排列(permutations)
查看>>
LeetCode第47题思悟—— 全排列 II(permutations-ii)
查看>>